Overview
You have an error in the QQube Synch log:
QBXMLSession_OpenConnection
File named Q:\Onion Construction Group LLC.QBW is not opened.
BeginSession
Error Code: 8004040A
A QuickBooks company data file is already open and it is different from the one requested.
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Cause
This error comes directly from the Intuit Software Development Kit (SDK) and indicates that it is seeing two possible QuickBooks files from which it can extract data, and that it is confused about which one it should communicate with.
There are five possible causes:
- You have two instances of QuickBooks open (under the same logged in user) on the same machine.
- Different QuickBooks File Name. You have QuickBooks open to a different file, OR the name of the QuickBooks file has been changed, and no longer matches the name that was originally used when added to the QQube Configuration Tool.
- Different QuickBooks Path. This generally occurs if somebody moves the QuickBooks file, and it is now different than what you originally setup inside the QQube Configuration Tool.
- Multiple QuickBooks company files. QuickBooks is open to a particular company file before attempting to load multiple company files.
- Incorrect Setup in a Remote Desktop/Terminal Services Environment. QQube is not installed in this environment according to these instructions.
Resolution
Cause 1. Make sure that there is only one copy of QuickBooks running at a time when performing a data refresh.
Causes 2 or 3. You can either change the QuickBooks company file name back to what was previously listed in the QQube Configuration Tool, or Add Company then Remove Company to reset the correct name. (You can't change the name of the company in the QQube Configuration Tool Directly).
Cause 4. Use the QQube Configuration Tool to change the path. This can only be done under the user where QQube was installed.
Cause 5. Open up QuickBooks to NO company file, before attempting to load multiple QuickBooks files. The Software Development Kit (SDK) does not allow developers to close a QuickBooks file that someone manually opened.
Cause 6. The synch takes place under the user where QQube is installed. However, regular users, in a multi-user implementation, may erroneously attempt to run the synchronizer under their own user name (or erroneously install an update under their own user name causing the synch to auto kick off), and cause errors like this to occur. A regular user is never a synch user unless you have a single-user on a workstation or laptop. If you are unfamiliar with the proper implementation, please review the installation and requirements guides
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