Overview
You have an error in the QQube Synch log:
Error Code: 80040414
A modal dialog box is showing in the QuickBooks user interface.
Your application cannot access QuickBooks until the user dismisses the dialog box.
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Cause
This error comes directly from the Intuit Software Development Kit (SDK) and indicates that it is unable to communicate with the requested QuickBooks file because a modal window needs to be dismissed before it can continue.
This works, just as if you were opening up QuickBooks manually - you would be unable to use the program, until you had dismissed the modal window in front of you.
If you are using the Mult-User version of QQube, this can only occur where the physical synch between QQube and QuickBooks is taking place - where you installed the multi-user server portion.
Common modal windows (See examples below):
- QuickBooks Advertisements
- Internet Security Levels Were Not Set Correctly warning (Seen on QuickBooks Server Installations)
- Intuit special account:
- Has not been created
- OR the QQube User doesn't have its own special account/e-mail
- QuickBooks Update Service
- QuickBooks Preferences to Modify Reports
- Reminders
EXAMPLES
Internet Security Levels
Intuit Special Account
QuickBooks Update Service
Modify Report:
Resolution
Modal windows MUST be closed before any third-party app can communicate with QuickBooks.
If you have a multi-user version of QQube that is implemented in a local or hosted server environment, the best way to approach the final resolution is to physically login to the synch session, and watch the synch kick off. The offending window that prevents QQube from talking to QuickBooks will become obvious.
QuickBooks Advertisements. You can shut this off within QuickBooks: Solved: How to stop popups? (intuit.com)
Internet Security Levels Warning. Addressed with this Intuit KB Article.
Intuit Special Account. Intuit requires a special Intuit account if you are using an Intuit service that interacts with the following information:
- Employee and Company Social Security Number
- Company Bank Details (Routing Number, Account Number)
- Accounts with bank or credit card numbers
- Customers with CC numbers
- Vendors with Tax ID
If this is the case:
- You cannot use the same Intuit special account you used for your admin account or other accounts
- You can only use this special Intuit account for this QuickBooks file. If you are aggregating multiple QuickBooks files in QQube, then every file will have a unique special Intuit account.
- You will NOT NEED to login every 90 days to change the password on this special account since it is only used to automatically login to QuickBooks.
QuickBooks Update Service. You should apply the update, but can get around this warning in a QQube server environment by simply leaving QB open to NO company file.
Modify Report. If you are using a Single-User copy of QQube then just close the Modify Report modal window. If you see this on the Multi-User Server QQube installation, then make sure this setting is Unchecked under the QQube user:
Alternative Causes
If you do not see any errors when logging and watching the process, there is only one other reason, that this would occur - an incorrect implementation.
The synch takes place under the user where QQube is installed. However, regular users, may erroneously attempt to run the synchronizer under their own username (or erroneously install an update under their own username causing the synch to auto kick off), and cause errors like this to occur. A regular user is never a synch user. If you are unfamiliar with the proper implementation, please review our installation guides.
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