Unable to Connect to QuickBooks Enterprise Server

Modified on Sat, 29 Jun at 3:35 AM

Overview

The log contains an error in the log similar to this:


<<<<<<<<<<<<<<<<<<<<<<<<<<<<<< 10/15/2024 06:44:57 PM >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
SybaseSession_ExecuteNonQueryCommand
ExecuteNonQuery
Unable to connect to server 'QQube_CustomReportingServer': [Sybase][ODBC Driver][SQL Anywhere]
Invalid user ID or password

CREATE EXISTING TABLE "41646d696e"."crp_AccountQuery" AT 'QQube_CustomReportingServer. v_lst_account'
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<


Cause

This refers to the QuickBooks Enterprise Custom Reporting Feature, from which QQube uses certain minor extractions to supplement the Intuit SDK.


There are four possible causes:

  1. The Custom Report User is now missing
  2. The Custom Report User password has changed
  3. The Custom Report User permissions have changed
  4. QuickBooks installation is corrupt or improper QB file permissions


Resolution

Cause 1. Refer to the instructions for setting up a Custom Report User.


Cause 2. Either change the password back to what it originally was...



- OR -


Change the password, then Remove the Company File in the Configuration Tool and then Add the Company File all in the same operation: 




Cause 3. check the permissions assigned to the QQube User:



Cause 4. There are multiple causes for QuickBooks related problems:

  1. Corrupt installation from an initial installation or release update.
  2. Database Manager is not properly tracking the folders where the QuickBooks file(s) exists.
  3. There are improper permissions on the QuickBooks file(s) itself. 


Run the QuickBooks utility to Repair File and Network Problems. (If using Multi-User QuickBooks, this should be done on the server).  You can also download the tool directly from here: Fix company file and network issues with QuickBooks File Doctor (intuit.com) 


Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us know how can we improve this article!

Select at least one of the reasons
CAPTCHA verification is required.

Feedback sent

We appreciate your effort and will try to fix the article